compliance server error when trying to access stellar.toml file

compliance server error when trying to access stellar.toml file

Manage alerts

Loading saved threads...

yulemata · External communityPost link
External question — Stellar Stack Exchange Author: yulemata Original post: https://stellar.stackexchange.com/questions/1610 License: CC BY-SA 4.0 — https://creativecommons.org/licenses/by-sa/4.0/ Adaptation: HTML converted to plain text; contact email addresses removed. I am testing compliance, bridge and federation servers simulating payments between two FI One of my compliance servers is displaying the following error when trying to contact the other FI: err="lookup federation server failed: get stellar.toml failed: http request failed with non-200 status code" . This seems a bit weird, I am able to get stellar.toml file from the other FI when using Postman or the browser. Furthermore, the federation server is also working and CORS is allowed. Any ideas??
Quote
Report
yulemata · External communityPost link
External answer — Stellar Stack Exchange Author: yulemata Original post: https://stellar.stackexchange.com/a/1654 License: CC BY-SA 4.0 — https://creativecommons.org/licenses/by-sa/4.0/ Adaptation: HTML converted to plain text; contact email addresses removed. I found out what the problem was. It turned out that the organization from which the tolm file was requested was not redirecting one of their server names correctly. Normally the compliance server will make a http request to the domain name after the * in a federation request. For example, if a federation address is user@email*domain.com and domain.com has server names as www.domain.com and domain.com, the compliance server will be making http requests to domain.com. This was the server name that was not correctly configured.
Quote
Report

Post Reply

Quoted from Forex.com.bd-Editorial External answer — Stellar Stack Exchange Author: yulemata Source score (net votes, not local likes): 0 Original post: https://stellar.stackexchange.com/a/1654 License: CC BY-SA 4.0 — https://creativecommons.org/licenses/by-sa/4.0/ Adaptation: HTML converted to plain text; contact email addresses removed. I found out what the problem was. It turned out that the organization from which the tolm file was requested was not redirecting one of their server names correctly. Normally the compliance server will make a http request to the domain name after the * in a federation request. For example, if a federation address is user@email*domain.com and domain.com has server names as www.domain.com and domain.com, the compliance server will be making http requests to domain.com. This was the server name that was not correctly configured.

Cancel quote

Checking account access…